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Methods
1. How do I - reset the Administrator password in DOORS when it has
been lost
To reset your password: you need to start DOORS in a mode that generates a keycode that you send to
support who will use it to generate a one time password to log in.
WARNING: Do not use this procedure when your database has System Usernames enabled. It is
strongly recommended you perform the procedure while working with a support engineer because
keycodes and passwords are session specific and can not be reused.
Starting Rational DOORS with the command-line switch you generate a key that will help you to log in.
Note: Database administrators can control users ability to reset the administrators password.
Information regarding authorized user control is discussed in the note below.
Steps to reset Administrator password
1. Create a shortcut for DOORS.exe file on your desktop
2. Right-click the shortcut and open the properties
3. Go to the SHORTCUT Tab of the Properties dialog box
4. At the end of the Target line left click after the closing quote
5. Hit the Space Bar once then add -otdbpw ""
Example:
"C:\Program Files\IBM\Rational\DOORS\9.3\bin\doors.exe" -otdbpw ""

6.

Note: Rational DOORS administrators who want to control the authentication process to reset
the Administrator password can set the database password. When the database password is set,
attempts to reset the Administrators' password without this information will result in a Rational
DOORS report window, with the message "invalid Password"
When the database password has been set by a DOORS administrator that value needs to be
included inside the quotes at the end of the switch. This password for the database, by default,
is not set. Use the DOORS Database Server Admin tool to set the database password; this will
prevent unauthorized users without knowledge of this information from resetting the
Administrators password. Using this shortcut the DOORS login window will display with an
additional Key field
Starting Rational DOORS from the shortcut displays the login window with the added Key field

This encryption key information is then provided to support who will use it to generate a one
time password to be used in that login window
You should not close this window; you need to type in the password provided by
support
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When the one time password is entered into the login window and you click OK
a dialog box is displayed with the message:
The password for user Administrator has expired, and must be changed before continuing

7.

Click OK to close the message window and open the Change Password DOORS dialog box

8.

Supply a new password that meets the requirements setup for password restrictions as defined
in the database properties

Once the Administrator password is reset the shortcut can be removed or at a minimum delete the
password reset switch and save the shortcut.
Legacy versions of Rational DOORS before 8.3 provided a UNIX-based client.
To reset the Administrator password on this platform:
1. Start Rational DOORS and include the switch -otdbpw
Example:
doors -otdbpw port@host from $DOORSHOME/bin
2.
3.

When DOORS starts a key will be returned in the login window
Send this key to your Rational Support team exactly as it appears
Support will provide a password to log in

For Rational DOORS 5.2
Follow the steps above without the use of quotes (as no database password could be set for this version
of Rational DOORS). Although information about Rational DOORS 5.2 is included here, this version is no
longer available. If you are using Rational DOORS 5.2, you should upgrade to a supported version as
soon as possible in order to receive support.

2.

How do I - convert layout DXL to attribute DXL

The values displayed in a layout DXL column are automatically recalculated whenever DOORS refreshes
your screen. If the DXL program associated with the column is CPU intensive, the constant recalculation
of the values can lead to slower performance. In this case you should consider using a DXL attribute
instead of a layout DXL column.
Answer
In DOORS there is a support tool that converts layout DXL to attribute DXL
1. Open the module view that contains layout DXL
2. Click Tools > Support Tools > Convert Layout DXL To Attribute DXL
A Convert Layout DXL - DOORS window is displayed listing all layout DXL columns
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3.

Click the names of the columns to be converted
(the convert button becomes enabled when you select an item)

4.

Click Convert to start the DXL conversion
A DOORS information window will display when the DXL is successfully converted

When complete each converted DXL
1. creates a new attribute named from the layout column heading the name
is prefixed with `DXL for ' to identify it as an Attribute DXL
2. adds an Attribute DXL column to the view
the column heading is the name of the Attribute DXL
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5.
6.
7.
8.

3.

Note: The Layout DXL is not removed after the conversion
Click OK to close conversion message window
Click Close to close the convert Layout DXL window
Right click Column Heading > Remove to remove Layout DXL columns from the view
Click View > Save as ... to save view changes

How do I - enable IBM Rational DOORS client-side logging

Rational DOORS Support may request you to enable client-side logging to further debug a problem
occurring in Rational DOORS client.
Answer
To enable Rational DOORS client-side logging, you need to run the following DXL from Rational DOORS
client before you start the operation you need to debug:
string logfileLocation = "c:\\temp\\doorsclientlog.txt"
int logLevel = 6
startLogging_(logfileLocation, logLevel)
After the operation that requires logging is done, you need to exit the Rational DOORS client, zip up the
log file, and send it to Support.
Note: There is no sensitive information in the log, only file transactions.
DOORS client-side logging is automatically disabled when you exit the DOORS client. You can also
disable logging by running the following DXL command:
stopLogging_()

4.

How do I - enable IBM Rational DOORS Database logging

How do you enable IBM Rational DOORS Database logging?
Cause
None of the DOORS administration tools have a logging option.
Answer
IBM Rational DOORS 8 and 9 logging has 6 levels of database logging.
Level 1 is the most terse and 6 the most verbose.
To find out an unspecified error, start logging at level 6 to capture all activity.
Once database logging has been enabled, reproduce the behavior and send the log file that is generated
in the location specified in the above steps to Rational Client Support.
IMPORTANT: Ensure to disable database logging logging after the issue has been reproduced since this
overhead may impact the performance.
For Microsoft Windows:
Disclaimer
This solution contains information about modifying the system registry. Before making any
modifications to the Microsoft Registry Editor, it is strongly recommended that you make a
backup of the existing registry. For more information describing how to back up the registry,
refer to Microsoft Knowledge Base article 256986
1. Open the registry editor on the server (Start > Run > type regedit)
2. Navigate to the following key:
3.
4.
5.
6.
7.

HKEY_LOCAL_MACHINE\SOFTWARE\Telelogic\DOORS_Server\9.x\Config
Create a new string value called logfile
Modify the string value and set its data value to: c:\doorslog.txt
Note: Use the path you have chosen on your host for the log file.
Create a new string value called loglevel
Modify the string value and set its data value to: 6
Restart the Rational DOORS Database Server
Note: All users need to be logged out of DOORS before attempting to restart the server

For UNIX and Linux:
Start the DOORS Database Server with the following options:
doorsd -p "port number" -L "log level" -l "path to log file"
Where <port number> is the DOORS Database port number and the path to the log file includes the file
name.
For example:
doorsd -p 36677 -L 6 -l /usr1/logs/DOORSusers.log
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5.

How do I - compare DOORS modules with Read-only access

Is it possible to compare modules in IBM Rational DOORS with only Read-only access permissions?
Cause
The module compare function is enabled but you can not successfully perform a comparison.
Answer
No. It is not possible to compare modules in Rational DOORS when you have only Read-only access
permissions.
To use the Module Comparison Wizard you must have at least write access to the module.
If you only have Read-only access permissions and attempt to run the comparison wizard, the following
message is displayed that prevents the comparison wizard from loading:
The newer module is not in exclusive edit.
Please close and reopen in exclusive edit.

6.

How do I - delete DOORS module baselines

When a baseline is no longer needed it can be deleted. However, you must be a DOORS user
type:Database Manager or Custom user with Manage database powers.
If you do not have correct permission the option to delete a baseline is not displayed.
Steps to delete a baseline:
1. Log into DOORS as a user with delete baseline privilege
2. Open the module exclusive edit mode
Using READ only, or Shareable edit mode the delete option is grayed out
3. Click File > Baseline > Delete
Note: The database must be enabled to permit baseline deletion.
If it is not a message will display prompting you to contact your Administrator.

The database default setting for a DOORS database is to not allow baseline deletion.
To enable baseline deletion you must log in as the user Administrator.
Steps to enable baseline deletion:
1. Log into DOORS as user Administrator
The option to enable baseline deletion is grayed out for all other users
2. Click the yellow database icon in the database explorer window
3. Click File > Properties (F2)
In the database properties window select the General Tab
4. Check the box to Allow deletion of module baselines in the section labeled Baseline Deletion
5. Click OK
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How do I – set the password expiration date in DOORS

7.

Edit your password setting to set when the password expires.
To show information about users:
1. Log in to Rational DOORS as a Project Manager, a Database Manager, or a Custom user who has
the power to create users.
2. Click the menu Tools > Manage Users
or
3.

Click Manage Users
Select the Users tab.

icon the in the Database Explorer

The list of users is displayed.

4.
5.

Select the user account whose password expiration you wish to set
Click Edit
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6.

Select the Security tab

7.

Type the value in the Expires after field
This is how long your passwords last before it expires. It is measured in days, starting from
when the password was last changed (see the Last changed box)
Once your password has expired, at login a prompt displays to change the password.
Note: By default, the value is 0 days, which means no prompt will ever show to change
password
after the first successful login.

8.

Click OK to close the edit users window

9.

Click Apply in the manage users window

10. Click OK to close the manage users window
Note: The first time you log into Rational DOORS, you are asked to change your password,
even if the value is set to 0 days.

8.

How do I - copy objects to another IBM Rational DOORS module

There are three method techniques that can be used:
 drag and drop
 Tools Function: Copy objects
 Edit: Paste special
Steps to copy using drag and drop selection
1. Exclusive Edit Open the modules you intend to copy from and copy to, in the module that
contains objects to be copied
2. Left click to select the first object in the group of objects to copy ( the object row border will
darken)
3. Scroll to the last object in the group, press Shift and left click mouse button (do not release
the left mouse button) the color for the group of objects selected changes to pink
4. Drag and drop the selection to the destination module where you intend to copy the objects
5. When you release the left mouse button a window displays
Choose Copy > below with hierarchy

6.

Note: If the module you are copying to already has objects, you may also copy after if you do
not want to insert below the object
Click Save
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Steps to copy using Copy Objects function
1. Exclusive Edit Open the modules you intend to copy from and copy to, in the module that
contains objects to be copied
2. Click Tools -> Filter -> Define to create a Filter criteria that passes the objects you need to
copy
3. Click Apply to filter the objects
4. Click OK to close the filter definition window
5. Click Tools -> Functions -> Copy Objects...
a. Click Browse to select the target module name
b. Click OK to close the selection window
c. Click down arrow to select the Copy Choice: Current display set
6.

d. Click OK
Click Save

Steps to copy using Paste Special function
To create a module with the same structure as an existing module, use Paste Special
1. Click the module name in the database explorer to select the item you intend to copy
the selected item background color will darken
2. Click Edit -> Copy to select the first object in the group of objects to copy ( the object row
border will darken)
3. Click Edit -> Paste Special

4.

9.

a. Type in the new module name and a description
b. Check the copy option: All objects
Note: The default copy option is Objects with object heading
and only default attributes and type are included
You need to specify custom defined attributes, types, links
If these items do not exist that option is greyed out
c. Check the option for Attribute definitions to copy custom defined attributes
Use the select button to choose which attributes to copy
d. Check the option Types to copy custom defined Type definitions
Use the select button to choose the types to copy
e. Check the option Links to copy object links for the default link module assigned
1. To use a different link module press Select
2. Uncheck the Link Option: Through same link module
this will allow you to select a different link module
3. Click close
e. Click the option External Links to include them as part of the copy
f. Click OK
DOORS will copy and leave open the new module
Click Save in the new module

How do I – understand about Rational DOORS history time and date

The time that is recorded is the time on the database server, not the time on the client.
It is stored in universal coordinated time (UTC) regardless of the time zone of the client or the server.
Related information
DOORS date and time formats

10. How do I - add previous baselined module into an open Baseline Set
Definition in IBM Rational DOORS
A baseline set is supposed to capture the data at that point. Once a module is baselined, the data at that
point becomes part of that baseline. Therefore, it is not possible to add previously created baselines to
baseline set definition.

Configuration
11. How do I - select enumerated attribute values for multiple Rational
DOORS objects
To select multiple Rational DOORS objects and to assign an enumerated attribute value for the objects,
apply the following steps:
1. Select the desired Rational DOORS objects by using the Shift key
2. Right click on the selected Rational DOORS objects
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3.
4.
5.
6.

Click Properties
Under the tab Attributes select the Enumerated Attribute
Click View/Edit
Select the value and Apply to Selected Objects.

This will set a desired single Attribute value for the selected Rational DOORS objects.
Note: This can be done only for the consecutive Rational DOORS objects and not the random objects in
the module.

12. How do I – understand the DOORS export to Excel column limit
Is there a limit to the number of columns that can be exported to Microsoft Excel from a module in IBM
Rational DOORS ?
Cause
Excel spread sheet is missing some columns after exporting a DOORS module.
Answer
Yes, there is a limit of 25 columns when exporting directly to Excel.
If you require more than 25 columns, use Export to Spreadsheet instead of using a comma-separated
or tab separated data as there is no such limit in the case of Export to Spreadsheet.

13. How do I – understand about the DOORS user name and password
for the training database
The example training database is populated with users intended to perform DOORS activities as part of
the Easy Start tutorial. However the login name and password details are not provided in the
documentation nor the installation instructions.
Answer
The Training database is populated with different users and types.
User names and passwords are case sensitive.
 The user name: Eric McCall has password set to: Training
Use this login ID for the exercises described in the Easy Start tutorial
(an interactive tutorial that presents DOORS concepts)
 The root level user: Administrator has password set to: salt1re
This login ID is the root level user for the training database
It is not required for the Easy Start tutorial

14. How do I – understand the access permission required to modify
DOORS attributes
To change the value of an attribute in a DOORS Formal module you need the following
permission:
1. Modify access to the Object
2. Modify access to the Attribute Value
3. Edit access to the object; for the module in Exclusive mode, or in Shared mode
with the object section locked
Restrictions:
For partitioned data the module containing the object must have modify permission
enabled in the exported partition and this permission is not denied in a currently
imported partition
The Attribute must allow user access. Some system defined attributes do not allow users
to change their value, for example the attribute:Last Modified On
Note: Access permission to the Attribute *Definition* allows you to modify its
characteristics, for example whether it logs history. This is different than the ability to
modify the object attribute value.
If you are creating an attribute definition, you cannot edit the access rights. You must
create (save) the attribute definition first, and then edit it to set the access rights.
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15. How do I - configure Rational DOORS to find Rational Publishing
Engine DXL
Attempts to use IBM Rational Publishing Engine (RPE) in Rational DOORS results in DXL error "could not
open include file".
Symptom
To use Rational Publishing Engine within Rational DOORS, DOORS needs to be able to find the RPE DXL
scripts. DOORS is configured automatically for this when RPE is installed, but certain configuration
changes may override these default settings.
Attempt to use IBM Rational Publishing Engine in DOORS results in DXL errors:
-E- DXL: <C:\Program Files (x86)\IBM\Rational\Publishing Engine\1.1.1.2\source\DOORS\dxl\doors
driver\getDOORSVersion.dxl:3>
could not open include file (source/DOORS/dxl/doorsdriver/getDOORSVersion.inc)
(No such file or directory)
-E- DXL: <C:\Program Files (x86)\IBM\Rational\Publishing Engine\1.1.1.2\source\DOORS\dxl\doors
driver\doorsToXml.dxl:3>
could not open include file (source/DOORS/dxl/doors driver/fileutils.inc) (No such file or directory)
Cause
IBM Rational DOORS is not configured to find the Rational Publishing Engine DXL scripts
Environment
This is common when IBM Rational DOORS is configured to access custom DXL scripts, either via the
registry or via the -addins switch in the DOORS startup shortcut
Diagnosing the problem
Inspect your Microsoft Windows Registry and look for a registry key similar to:
 64 bit Windows:
HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Telelogic\DOORS\9.3\Config\Addins
 32 bit Windows:
HKEY_LOCAL_MACHINE\SOFTWARE\Telelogic\DOORS\9.3\Config\Addins
Also check for Addins registry keys in the HKEY_CURRENT_USER equivalent of the above paths -on 64 bit systems, check both paths
Resolving the problem
If you are using the Microsoft Windows Registry to set the IBM Rational DOORS Addins value, all the
custom DXL paths, including the RPE DXL path, need to be specified in the HKEY_LOCAL_MACHINE
Addins registry key. Do not specify custom DXL paths in the HKEY_CURRENT_USER Addins registry key,
as that will override any existing HKEY_LOCAL_MACHINE Addins registry key.
If you are using the -addins (-a) switch to configure Addins, ensure that any existing paths from the
HKEY_LOCAL_MACHINE Addins registry key are also included in the -addins switch.
You can specify multiple paths by separating them with a semi-colon (no extra spaces after the semicolon). If using the -a switch, use double quotes around all the paths, if any of the paths have spaces in
their names. For more details on Addins configuration and syntax, please refer to Tech Note #1421641
Related information
Configuring DOORS to use custom DXL scripts
Resolving include file errors when using RPE in DOORS

16. How do I – understand the DOORS Help System Web Archive (WAR)
file
Where can you down load the Help System Web Archive (WAR) file used to set up an intranet server for
IBM Rational DOORS?
You can obtain the WAR file from the Rational documentation download site.
Related information
Delivering help content from an intranet server

17. How do I – understand the registry path for DOORS 9.3 on Microsoft
Windows 7 64-bit
Where do you update the Windows registry entries for IBM Rational DOORS on a Windows 7 64-bit
machine?
Cause
The registry path for DOORS 9.3 on Windows 7 64-bit has changed
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Answer
The registry path for DOORS 9.3 in Windows 7 64-bit is:
[HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Telelogic\DOORS\9.3\Config]
Any changes to the configuration of DOORS that require registry edits should be made in this location.
REGISTRY EDITS:
This solution contains information about modifying the system registry. Before making any
modifications to the Microsoft Registry Editor, it is strongly recommended that you make a
backup of the existing registry. For more information describing how to back up the registry,
refer to Microsoft Knowledge Base article 256986

Integration
18. How do I – understand why an IBM Rational DOORS export to
Rational Quality Manager (RQM) hangs
Export attempts from an IBM Rational DOORS module to Rational Quality Manager (RQM) hang -- there
is no indication that the export completes in the DOORS client, though you may see the data make it to
RQM.
Cause
When installing the IBM Rational Quality Manager Interface (RQMi) components, both the RQM user and
the DOORS user to be used with RQMi need to already exist. If the RQMi components were installed the
very first time DOORS was installed (that is, when the DOORS RQMi user did not yet exist), you may see
this problem.
Resolving the problem
To resolve this problem, stop the IBM Rational DOORS Quality Manager Interface (RQMi) and DOORS
servers, then reinstall the DOORS client, including the RQMi components.

Database and Server
19. How do I – install DOORS client to the database server machine
Is it possible to install the IBM Rational DOORS client to a different directory from where the database
server program files are installed?
Cause
DOORS installer has a custom option that states you can choose the directory location to install.
If you attempt to perform a custom install of the DOORS client on a machine that already has DOORS
database server installed you do not get the option to pick the directory location where to install the
client program files.
Answer
No. When you install the DOORS client program files to a machine where the DOORS database server
(ddbs) is installed the files are installed to the same directory.
WORKAROUND:
Remove the database server before you install the DOORS client to the desired location. You can then
reinstall ddbs to a separate location.
Related information
Different DOORS client and server file versions

20. How do I - run IBM Rational DOORS client and server with different
fix pack versions
When you install IBM Rational DOORS Web Access 1.4.0.4 on the same server as DOORS 9.3.0.5, you
need Interoperation Server 9.3.0.4. On Windows, this results in one system with different versions of the
DOORS client and server, which may cause problems.
Symptom
When the IBM Rational DOORS client and DOORS server have different fix pack versions but are both
installed to the default location, you may encounter unexpected behavior like:
 Rational DOORS Web Access (DWA) being unresponsive
 DOORS dbadmin command not working correctly
 DWA Interoperation Server not working correctly
Cause
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When the IBM Rational DOORS client and DOORS server have different fix pack versions but are both
installed to the default location, some of the binary files overwrite each other, and they may conflict
because of the different fix pack versions. This problem does not occur if both the DOORS client and the
DOORS server are at the same fix pack version.
Environment
This has been seen on Windows systems where the IBM Rational DOORS client and DOORS server have
different fix pack versions but are both installed to the default location on the same machine.
Diagnosing the problem
server version are slightly different, and you installed both to the default location, you may have
problems from conflicting binaries.
Resolving the problem
There are two ways to resolve this issue:
 Use Custom installations to install the DOORS client and DOORS server to different locations
 Use the same fix pack version for the DOORS client and DOORS server, when installing
components on the same machine, if you want to use the Typical installation
If you are already having this problem, you should schedule downtime and then:
1. Stop DOORS
2. Uninstall the DOORS server (this does not remove your database)
3. Uninstall the DOORS client
4. Reinstall the DOORS client and the DOORS server as described above

21. Fix List for Rational DOORS 9.3
Fix List for Rational DOORS 9.3

22. How do I – understand the download instructions for Rational
DOORS v9.3.0.5
Where can I download IBM Rational DOORS fix pack 9.3.0.5 for Windows?
Cause
Finding the correct download location for DOORS fix packs is difficult.
Answer
The DOORS 9.3.0.5 client and server can be downloaded and installed from the IBM Fix Central web site
located at:
http://www-933.ibm.com/support/fixcentral/
1. For Product Group, select "Rational"
2. For Product, select "IBM Rational DOORS"
3. For Installed Version, select "9.3"
4. For Platform, select "Windows 32-bit, x86"
5. Click "Continue"
6. On the "Identify fixes" page, make sure the radio button next to "Browse for fixes" is filled. Click
"Continue"
7. On the "Select fixes" page, check the box next to "fix pack: 9.3.0.5-RATIONAL-DOORS-fixpack5"
and click "Continue"
8. Sign in with your IBM ID and password
9. On the "Download options" screen, select the "Download using your browser (HTTP)" button and
click "Continue"
10. On the "Download files using HTTP", select "ratlDOORS_Client_9-3-0-5.zip (231.45 MB)" and
"ratlDOORS_Server_9-3-0-5_Windows.exe (318.91 MB)" which should start the downloads.
Related information
4030983: DOORS 9.3.0.5 download document

23. How do I – understand running IBM Rational DOORS client and
server with different fix pack versions
When you install IBM Rational DOORS Web Access 1.4.0.4 on the same server as DOORS 9.3.0.5, you
need Interoperation Server 9.3.0.4. On Windows, this results in one system with different versions of the
DOORS client and server, which may cause problems.
Symptom
When the IBM Rational DOORS client and DOORS server have different fix pack versions but are both
installed to the default location, you may encounter unexpected behavior like:
 Rational DOORS Web Access (DWA) being unresponsive
 DOORS dbadmin command not working correctly
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DWA Interoperation Server not working correctly

Cause
When the IBM Rational DOORS client and DOORS server have different fix pack versions but are both
installed to the default location, some of the binary files overwrite each other, and they may conflict
because of the different fix pack versions. This problem does not occur if both the DOORS client and the
DOORS server are at the same fix pack version.
Environment
This has been seen on Windows systems where the IBM Rational DOORS client and DOORS server have
different fix pack versions but are both installed to the default location on the same machine.
Diagnosing the problem
Launch the IBM Rational DOORS client and run the Help > About command. If the client version and the
server version are slightly different, and you installed both to the default location, you may have
problems from conflicting binaries.
Resolving the problem
There are two ways to resolve this issue:
 Use Custom installations to install the DOORS client and DOORS server to different locations
 Use the same fix pack version for the DOORS client and DOORS server, when installing
components on the same machine, if you want to use the Typical installation
If you are already having this problem, you should schedule downtime and then:
1. Stop DOORS
2. Uninstall the DOORS server (this does not remove your database)
3. Uninstall the DOORS client
4. Reinstall the DOORS client and the DOORS server as described above

24. How do I - migrate Doors database from one server to another server
Steps to move or transfer a DOORS database from one server to another:
1. All users should save and close any open modules then exit DOORS
2. DOORS db admin should verify there are no locked Modules
Click Tools > Manage Locks in DOORS database Explorer
Select any locked item and click Unlock
3. Stop the DOORS Database server
4. Backup the data folder
On Windows, the location of the Data folder can be found from the registry key "ServerData”
present in the path:
HKEY_LOCAL_MACHINE\SOFTWARE\Telelogic\DOORS_Server\x.x\Config
x.x being the version of DOORS
5.
6.
7.

On UNIX or Linux these values are set as environment variables
If you are installing DOORS database server on a new server
copy the data directory to that machine. You can browse to that directory
where you have copied the data while installing the database server
If you have already installed the DOORS database server and it had created a brand new data
directory, follow stop the DOORS DB Server service and then replace the entire data directory
contents with the backup data from the other server ( step 4 above)
Restart the DOORS DB server service and then login as Administrator
Use the password set for Administrator on the original database

Problems and Issue
25. How do I – understand why Instructions incorrectly reference use of
the Local Help Updater
Attempts to use the instructions to configure help content using the local help updater is not an option
from the IBM Rational DOORS Help menu.
Symptom
Instructions to configure help content suggest the local help updater is an option from DOORS Help menu
but there is no such option.
Cause
This has been identified as a product defect under APAR PM56472.
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Environment
The default for help delivery draws content from the Web dynamically.
You can also have the help content installed locally on your computer; this is setup using the Local Help
Updater.
Resolving the problem
There are two methods to load the help updater
 Use the Help viewer File menu option
 Enter the URL to the update WAR file in an external browser
Note In order to use Help Updater local content URL must be enabled in content preferences
In the
1.
2.
3.
4.

Help Viewer
Open Help preferences
Select the open mode option in the Help Viewer
Close and Reopen the Help
Click File > Local Help Updater

In External Browser
Enter the address of the local help URL including the update WAR file.
For example:
http://127.0.0.1:63650/help/updater/updatewar.jsp

26. How do I – understand why opening a Microsoft Word document
results in "A certificate has expired" error in Rational DOORS
Attempts to open a Microsoft Word document results in the error "A certificate (signing or issuer) has
expired" using IBM Rational DOORS.
Cause
The certificate of doors.dot is expired.
Resolving the problem
The updated certificate will be included in a future Rational DOORS fix pack.
WORKAROUND:
Use the doors.dot file attached below.
Update the doors.dot file as follows:
1. Identify the Microsoft Word startup folder
2.

In Microsoft Word go to Tools/Option/File locations
Replace the doors.dot of the startup folder with the new one.

Disclaimer
All source code and/or binaries attached to this document are referred to here as "the
Program". IBM is not providing program services of any kind for the Program. IBM is
providing the Program on an "AS IS" basis without warranty of any kind. IBM WILL
NOT BE LIABLE FOR ANY ACTUAL, DIRECT, SPECIAL, INCIDENTAL, OR
INDIRECT DAMAGES OR FOR ANY ECONOMIC CONSEQUENTIAL DAMAGES
(INCLUDING LOST PROFITS OR SAVINGS), EVEN IF IBM, OR ITS RESELLER,
HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES.

doors.dot

27. How do I – understand why generating a DOORS support request
results in supportinfo.exe error
Attempts to add video captures to a Support Request created in IBM Rational DOORS results in the error
"Generate support request has encountered a problem and needs to close".
Symptom
DOORS help menu has the option to generate a support request.
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When you Click add video capture an error results:
Generate support request has encountered a problem and needs to close
Cause
The dynamic link library (DLL) for the video capture function needs to be registered in Microsoft
Windows.
Resolving the problem
This functionality in DOORS is being phased out and is replaced by the IBM Support Assistant (ISA)
plugin that is available in DOORS.
WORKAROUND:
1. Close the DOORS client
2. Open a command prompt (Click Start > Run > type cmd)
3. Navigate to C:\Program Files\Common Files\ibm\Rational\Shared\CFM\2.1
4. Run the command:
regsvr32 "BB FlashBack Player.dll"
The following window displays

5.
6.

Click OK
Restart the DOORS client

28. How do I – understand why starting DOORS results in "Application
failed to initialize properly (0xc0000022)" error
Attempts to start IBM Rational DOORS results in the error "Application failed to initialize properly
(0xc0000022). Click on OK to terminate the application".
Symptom
The user Administrator can run DOORS but the domain user or local users can not start DOORS.
The error has been reported for users on Windows NT or Windows 2000 machines which are members of
a domain, and sometimes on machines which are part of a workgroup.
Typically this occurs on a single workstation.
Cause
Permission issues.
Environment
Windows NT and Windows 2000
Diagnosing the problem
The files which DOORS loads before displaying the splash screen are listed below.
 Windows NT4 loads the following files:
winspool.drv, oledlg.dll, dutb32.dll, rpcltc1.dll, doorsdxl.tlb
 Windows 2000 loads the following files:
wsock32.dll, ws2_32.dll, ws2help.dll, winspool.drv, oledlg.dll, netapi32.dll, secur32.dll,
netrap.dll, samlib.dll, dnsapi.dll, dutb32.dll, lpk.dll, usp10.dll, doorsdxl.tlb, clbcatq.dll
These files normally reside in the WinNT\System32 directory, apart from the file dutb32.dll which resides
in $DOORSHOME\bin. DOORS needs access to these files or the error listed above may appear in a
Windows popup dialog before the DOORS splash screen appears.
Resolving the problem
To resolve the issue, set access rights for the group Everyone equal to read and execute privilege
for the file: $DOORSHOME\bin\dutb32.dll.
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Note: In some cases, you may need to add the Domain User as a local user on the NT or Win2000
machine. The Domain User must then be given read and execute rights to the file dutb32.dll.

29. How do I – understand why the DOORS DXL rich text function
outputs double backslash characters
Attempts to export text that contains the backslash character \ using IBM Rational DOORS rich text in
string function in combination with .text results in double backslash characters \\ in the output.
Symptom
The DXL output is returning two backslashes for every one backslash contained in the text.
Steps to reproduce:
Run the following DXL for an open module that contains an object with a backslash in the text:
Object o
for o in current Module do {
string rts = richText( o."Object Text" )
RichText rt
for rt in rts do {
string plainText = rt.text
print plainText "\n"
}
}[</code>]
Expected results: A single backslash is rendered in the output.
Actual results: Two backslashes are rendered in the output (see image below).
image

Cause
For text that contains file path locations stored in a DOORS attribute, the exported information will not
let you get to the file.
Diagnosing the problem
Verify the issue:
1. Create a Wordpad document
2. Insert a single backslash \
3. Save document as RTF file
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4.

Open the Wordpad document in Notepad to see its RTF markup
You will notice that the single backslash entered is actually stored after being escaped with
another
backslash ( \\ double-slash).
Example: {\rtf1\ansi\ansicpg1252\deff0\deflang1033{\fonttbl{\f0\fnil\fcharset0 Calibri;}}
{\*\generator Msftedit
5.41.21.2510;}\viewkind4\uc1\pard\sa200\sl276\slmult1\lang9\f0\fs22\\\par
}

5.
Resolving the problem
This is expected behavior.
By convention, the backslashes are stored in the actual RTF markup as escaped (inserted backslash) so
that any RTF reader cannot mix them up as part of the RTF syntax.
So when you get the rich text version of a string that contains a backslash, it gives you what it actually
stored which is \\ for a single slash.
If you print the object text as plain text, it is shown as a single slash.

30. How do I – understand why opening a module in IBM Rational
DOORS results in the error: Unable to open module... No such file or
directory
When trying to open a formal module DOORS Report message displays:
'Unable to open module '.../.../ModuleName' No such file or directory C:\Program
Files\IBM\Rational\9.x\data\v6\...\...\m000xxxx1.mod\current.ver\treedata.dtc'
Symptom
An IBM Rational DOORS database manager type opens a module and a Rational DOORS Report message
displays:
'Unable to open module '.../.../ModuleName' No such file or directory C:\Program
Files\IBM\Rational\9.x\data\v6\...\...\m000xxxx1.mod\current.ver\treedata.dtc'
The module is visible but cannot be open.
Environment
Treedata files contain 'cached' encrypted/compressed token data.
There are crucial data files the
 The current version of
 The backup version of
 The change version of

database server creates or modifies during an update transaction.
a file ends with a .dtc extension.
a file ends with a .dtb extension.
a file ends with a .dtn extension.

During a file modification transaction, updates are stored in a temporary file with a .dtn extension.
Upon completion of the transaction, the current data is saved for backup as a .dtb file and the changed
.dtn file is saved as the current data file.
This is performed during the successful closing of a transaction 'cache'.
Note: .dtn files should only exist during a transaction. The presence of any dtn files beyond that time
indicates a failed data update.
Diagnosing the problem
The Rational DOORS Report Window error message should contain the location of the problem data file.
Make a note of the data path you will need to navigate to that location in the data area.
You can also use a module's unique ID to determine the folder location of the data files.
1. Click File -> Module Properties... (in the module)
2. Select the General Tab (on the module properties window)
The URL lists the module's unique ID at the end of the
string//DOORS_Server:36677/?version=2&prodID=0&urn=urn:telelogic::1-49c3dc9d5b077687M-000xxxx1
Resolving the problem
If the current version of the data file is missing, the backup .dtb file may be used as a potential
replacement.
Here are the steps to replace the missing file.
Note: No users should be logged into the project with the problem module opened.
1. Make a copy of the directory as a backup
2. Navigate to the server data directory location identified for the problem module
3. Open the Current Version directory
4. Rename the treedata.dtb file from this directory to treedata.dtc
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5.

Restart the DOORS server

If the problem is not resolved after renaming the file, you need to obtain a working copy of the .dtc file
from system backup of the last known good version of the data file and paste it in the directory.

This website is published "as is". There is no warranty of any kind (express or implied) as to the operation of
our site, the accuracy of the information or the services or products referred to on it. All warranties are
excluded as far as permitted at law. Neither we nor any third party will be liable for any losses or damage that
may result from use of the website or as a consequence of any inaccuracies in, or any omissions from, the
information which it contains.
Registered Office:
SAMECS House
22 Sparrowhawk Way
TELFORD TF1 6NH
Tel: 01952 248593
Web site: www.samecs.co.uk
E-Mail: support@samecs.com

Register in England No: 4824835
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